В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Каала
Каала
05.06.2020 19:56 •  Информатика

Составьте программу на языке паскаль для подсчета суммарного числа букв "е" и "о" в строковой величине

Ответ:
ОСЕНЬ2019
ОСЕНЬ2019
02.10.2020 06:48
Var s:string; j,p:integer;
begin readln(s); p:=0; for j:=1 to length(s) do if(s[j]='e')or(s[j]=o)then inc(p); writeln(p); readln end.

var s:string; j,e,o:integer;
begin
readln(s); e:=0; o:=0;
for j:=1 to length(s) do begin if s[j]='e' then inc(e); if s[j]=o then inc(o);
if o > e then writeln('o'); if o < e writeln('e'); if o=e then writeln('oe'); readln
end.

Счет букв ведется для латинских строчных букв o и e.)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?