В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
12Камилла1
12Камилла1
25.03.2020 08:45 •  Информатика

Дан одномерный массив целых чисел.написать программу подсчёта количества положительных и отрицательных чисел массива.

Ответ:
sasharomanov03
sasharomanov03
02.10.2020 06:25
Var ar : array [1..100] of integer;
i, pluscount,minuscount,zerocount : integer;
begin
readln(n); -считываем число элементов массива(если оно дано, я не знаю)
for i := 1 to n do
begin
read(ar[i]);  - считываем элемент массива, заносим его в массив
if (ar[i] > 0) then pluscount := pluscount+1; -если >0 -> увел. счетчик пол.чисел
if (ar[i] < 0) then minuscount := minuscount+1; -если <0 -> увел. счетчик отр.чисел
if (ar[i] = 0) then zerocount := zerocount+1; -если =0 -> увел. счетчик нулей
end;
writeln('В массиве ',pluscount,' положительных чисел, ',minuscount,' отрицательных чисел, ',zerocount,' нулей.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?