В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kesha4444
Kesha4444
26.12.2022 22:29 •  Информатика

Составить программу вычисление площади треугольника по трём сторонам. s=1\2aha

Ответ:
прп30
прп30
16.07.2020 11:45
По трем сторонам - формула Герона.
var a,b,c,p:real;
begin
write('Введите стороны: ');
readln(a,b,c);
p := (a + b + c) / 2;
writeln('Площадь равна ', sqrt(p * (p - a) * (p - b) * (p - c)):9:4);
end.

А через основание и высоту (твоя формула):
var a,h:real;
begin
write('Введите длину основания и высоты, проведенной к нему: ');
readln(a, h);
writeln('Площадь равна: ', (a * h) / 2:9:4);

:9:4 -- это такой оператор, который выводит число в формате с фиксированной точкой и 4 знаками после запятой.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?