В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
roleman
roleman
24.11.2020 00:30 •  Информатика

Надо составить программу. дана последовательность натуральных чисел а1, а2, аn. создать массив из нечетных чисел этой последовательности если таких нет, выведите сообщение об этом факте. надо

Ответ:
aleksinia
aleksinia
16.07.2020 10:21
Var
m:array [1..10000] of integer;
a,n,i,j:integer;
begin
  writeln('Введите n:');
  readln(n);
  j:=0;
  writeln('Введите последовательность чисел:');
  for i:=1 to n do
  begin
  readln(a);
  if (a mod 2)<>0 then begin j:=j+1; m[j]:=a; end;
  end;
  if j=0 then writeln ('Нечетных чисел нет в данной последовательности.')
  else
  begin
  writeln ('Нечетные числа в данной последовательности:');
  for i:=1 to j do
  write(m[i],' ');
  writeln;
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?