Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Reeezz
17.10.2022 10:44 •
Информатика
Дан массив из 50 вещественных чисел, среди которых есть и положительные и отрицательные и равные нулю. среди положительных найти максимальный элемент.
Ответ:
Eliseevka12
15.07.2020 22:06
#include <stdio.h>
char main(void)
{
char A[50], n = 50,i,max;
srand(time(0));
printf("Array A[50]: \r\n ");
for (i=0; i<n; i++)
{
A[i] = -5+ rand(0) %10;
printf("%d ", A[i]);
}
max = A[0];
for (i=0; i<n; i++)
{
if (A[i]>max)
{
if (A[i]>0) max = A[i];
}
}
printf(" \r\n Max: %d ", max);
}
0,0
(0 оценок)
Популярные вопросы: Информатика
dfyz2
07.07.2022 16:21
задания 2задания 3задания...
ANI577
22.06.2020 08:29
нужно составить программу...
ismailovigbal13
24.05.2021 23:23
Расскажите об интерактивной веб-странице и приведите примеры...
Настён1989
11.03.2022 23:48
Scratch програмаллау ортасында нысанды қалай атайды...
MarryDied
29.08.2021 04:23
Записать развёрнутую форму чисел 1654 , 18,35,1,137,19 надо...
ailonkilo
27.12.2022 10:29
Процессы происходящие в литосфере??? за. ответ...
Катерина090807
10.04.2021 05:23
Төмөнкү тактоочторду катыштырып суйломдорду түзгүлө: илгери, ылдам, кыргызча, көп, бүгүн, эртең....
Amarov
28.03.2020 20:28
Найдите сумму модулей чисел? -8, 7, 6, -5, 0, 20...
pasatnuk
30.03.2022 18:55
101²+11² =10110²-101²=информатика...
zalinairina9
30.03.2022 18:55
Кому принадлежат слова? «Верховная власть в Англии и входящих в нее территориях должна отныне принадлежать народному представительству; в выборах должны иметь свой...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
char main(void)
{
char A[50], n = 50,i,max;
srand(time(0));
printf("Array A[50]: \r\n ");
for (i=0; i<n; i++)
{
A[i] = -5+ rand(0) %10;
printf("%d ", A[i]);
}
max = A[0];
for (i=0; i<n; i++)
{
if (A[i]>max)
{
if (A[i]>0) max = A[i];
}
}
printf(" \r\n Max: %d ", max);
}