В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nady0208
Nady0208
07.01.2022 03:13 •  Информатика

Pascalabc 1. напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами. например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.

Ответ:
Mirskaya
Mirskaya
02.10.2020 05:35
Var  
 a,b,i : integer;    
 begin 
  readln (a,b); 
   for i := (a+1) to (b-1) do 
   if i mod 2 = 0 then 
     writeln (i); 
end.

вроде работает pascalABC.Net
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?