В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
федя666
федя666
09.11.2021 09:31 •  Информатика

А)одномерный массив a заполнен десятью случайными целыми числами от 1 до 20. напишите программу вывода элементов массива в обратном порядке. б)напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.

Ответ:
Mlpoiuytrewqazxcvbn
Mlpoiuytrewqazxcvbn
15.07.2020 20:48
А)
var
a:array[1..10]of integer;
i:integer;
begin
for i:=1 to 10 do
  a[i]:=random(20)+1;
for i:=10 downto 1 do
  write(a[i],' ');
end.
б)
var
a:array[1..20]of integer;
i:integer;
begin
for i:=1 to 20 do
  a[i]:=random(11*i)+10*i;
for i:=1 to 20 do
  if i mod 2=1 then write(a[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?