В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
socnyjarbuz
socnyjarbuz
31.05.2022 00:48 •  Информатика

Язык - pascal. даны натуральное число n и последовательностьa1, an. составьте программу,которая находит среднее арифметическое тех элементов последовательности, которые кратны 3 и не кратны 9

Ответ:
Серафим6776
Серафим6776
15.07.2020 20:45
Var
 n, i, s, a, k: integer;
begin
readln(n);
s := 0;
k := 0;
for i := 1 to n do
begin
read(a);
if (a mod 3 = 0) and (a mod 9 <> 0) then
begin
inc(k);
inc(s, a);
end;
end;
write(s div k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?