В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
danilgrekov20
danilgrekov20
23.01.2022 14:35 •  Информатика

Написать программу в ! составить процедуру, заменяющую в исходной строке символов все единицы нулями и все нули единицами. замена выполняется, начиная с заданной позиции строки.

Ответ:
2006ksenia2006
2006ksenia2006
15.07.2020 20:00
Var
k:integer;
s:string;
procedure Zamena(var ss:string; p:integer);
var
i:integer;
begin
for i:=p to length(ss) do
begin
if ss[i]='1' then ss[i]:='0' else
if ss[i]='0' then ss[i]:='1';
end;
end;
begin
writeln('Введите строку: ');
readln(s);
writeln('Введите позицию с которой начинать замену: ');
readln(k);
Zamena(s,k);
writeln('Измененная строка: ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?