В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу паскаль и объясните ее дано четырехзначное число,получить новое поменяв местами первую и последнюю цифру

Ответ:
Dizig
Dizig
02.10.2020 05:26
Program zamena;
var s:string;
     x,y:char;
begin
write('Введите четырехзначное число: ');
readln(s);
x:=s[1]; y:=s[4];
s[1]:=y; s[4]:=x;
writeln('Полученное число: ',s);
end.

Считываем число как строку. Символьной переменной "X" присваиваем значение первого символа строки (первой цифры числа). Символьной переменной "Y" присваиваем значение четвертого символа строки (четвертой цифры числа). Делаем обмен первой и четвертой цифры числа: присваиваем первому символу значение переменной "Y", а четвертому символу - значение переменной "X". Выводим получившуюся строку (число) на экран.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?