В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Valinka9999
Valinka9999
24.02.2022 16:21 •  Информатика

Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному. входные данные в первой строке записаны через пробел размеры матрицы: количество строк n и количество столбцов m ( 1 ≤ n , m ≤ 100 ). в следующих n строках записаны строки матрицы, в каждой – по m натуральных чисел, разделённых пробелами. выходные данные программа должна вывести все столбцы, в которых есть элемент, равный максимальному элементу в матрице. каждый столбец выводится в одну строку, элементы разделяются пробелами.

Ответ:
boda13
boda13
02.10.2020 05:25
Pascal
program matr;uses CRT;var fl:char;a:array [1..100,1..100] of integer;i,j,m,n,mmax:byte;max:integer;label met;beginmet:clrscr;max:=0;writeln ('Введите размерность матрицы NxM');readln (n);readln (m);randomize;for i:=1 to n do beginfor j:=1 to m do begina[i,j]:=-50+random(101);write (a[i,j]:4);end;{создание и вывод матрицы}writeln;end;writeln;for i:=1 to n do{нахождение максимального элемента}zfor j:=1 to m doif (a[i,j]>max) then beginmax:=a[i,j];mmax:=j;end;for i:=1 to n dowrite (a[i,mmax]:4);writeln;{Вывод столбца}for i:=1 to n do {нахождение одинаковых элементов}for j:=1 to n doif (a[i,j]=max)and(j<>mmax) then begin mmax:=j;write (a[i,mmax]:4);end;writeln ('Для продолжения нажмите любую клавишу,для выхода - "Х"');readln(fl);if (fl <> 'x') then goto met;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?