Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
05Karishka0531526654
24.02.2022 16:21 •
Информатика
Дан массив а размера n. найти максимальный элемент из его элементов с нечетными номерами а1,а3, вывести их индексы
Ответ:
Nastya45t7
02.10.2020 05:25
var
arr: array[1..100] of integer;
i, n, max: integer;
begin
max:=1;
readln(n);
for i:=1 to n do
begin
arr[i]:=random(100);
write(arr[i], ' ');
if (arr[i]>arr[max]) and (i mod 2<>0) then max:=i;
end;
writeln;
writeln(arr[max]);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
кастусь
10.09.2020 11:05
Отметьте допустимые имена переменных *Super34TVopros?AaA+BВасяT34abMyVariableIsBestVariable...
alenaalefirova
18.05.2021 16:51
Какую клавишу необходимо нажать для того, чтобы приступить к вводу нового абзаца?deletespaceEnterShift...
Kiryshka2532
03.04.2020 16:50
Выбрать правильный ответ......
superrobbot2000
01.05.2021 01:49
Сформировать одномерный массив, каждый элемент которого равен количеству нечетных отрицательных элементов соответствующей строки двумерного массива....
ОверДовн
01.05.2021 01:49
Даны две дроби a/b и c/d (a,b,c,d-натуральные числа). составить программу для умножения дроби на дробь. результат должен быть несократимой дробью. желательно через процедуру....
alyonaapresyan
01.05.2021 01:49
Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину.программу нужно написать в паскале пример,как должно получиться введите...
132132456789
21.01.2020 03:47
Програмні засоби комп‘ютерної графіки...
misterbango
19.11.2021 17:30
На заводе два параллельно расположенных конвейера движутся в противоположных направлениях, один - со скоростью 50 см/с, а другой - 0,3 м/с. с какой скоростью перемещаются...
Екатерина13250804
19.11.2021 17:30
Близьке за значенням до слова підобідують...
koshka99
19.11.2021 17:30
Какой из перечисленных этносов самый малочисленный? 1. ненцы 2. карелы 3. чуваши 4. татары...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
arr: array[1..100] of integer;
i, n, max: integer;
begin
max:=1;
readln(n);
for i:=1 to n do
begin
arr[i]:=random(100);
write(arr[i], ' ');
if (arr[i]>arr[max]) and (i mod 2<>0) then max:=i;
end;
writeln;
writeln(arr[max]);
end.