В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
angelina2410
angelina2410
03.12.2020 15:07 •  Информатика

Составить программы : ) 1.введено четырехзначное число. найти сумму цифр, кратных 3-м. 2.определить, сколько среди заданных чисел a, b, c, d отрицательных. 3.составить программу, которая выводит меню и при нажатии нужной цифры вычисляет соответствующее выражение: 1 - y= x3 + x 2 - y= (x +1)2 3 - y= sqr(x+4)

Ответ:
zavirohinoleksa
zavirohinoleksa
02.10.2020 05:15
1)
var a:array [1..4] of integer;
var x,i,i1: integer;
begin
writeln('Введите 4-х значное число');
read(x);
for i:=1 to 4 do begin
a[i]:=x mod 10;
if a[i] mod 3 = 0 then begin
i1:=i1+a[i];
end;
x:=x div 10;
end;
write(i1);
end.

2)
Немного не понял:
var a:array [1..4] of integer;
var i,n,y: integer;
begin
n:=1;
for i:=1 to 4 do begin
writeln('Введите ',n, ' число');
read(a[i]);
if a[i]<0 then y:=y+1;
n:=n+1;
end;
write('Отрицательных чисел: ',y);
end.

3)
var i,y,x: integer;
begin
writeln('Выберите действие: 1)y=x^3 + x; 2)y=(x+1)^2; 3)y=sqr(x+4)');
read(i);
if i=1 then begin
writeln('Введите x');
read(x);
write('y=',(x*x*x)+x);
end
else begin
if i=2 then begin
writeln('Введите x');
read(x);
write('y=',(x+1)*(x+1));
end
else begin
if i=3 then begin
writeln('Введите x');
read(x);
write('y=',sqrt(x+4));
end;
end;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?