В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ясминка2006
Ясминка2006
31.08.2021 02:26 •  Информатика

Паскаль составить программу, которая выводит меню и при нажатии вводе цифры вычисляет соответствующее выражение: 1 - y= (a+b)^2 2 - y= a^2-b^2 3 - y= 1/(a+b)

Ответ:
minzilyana
minzilyana
02.10.2020 05:15
Var i,y,a,b: single;
begin
writeln('Выберите действие: 1)y=(a+b)^2; 2)y=a^2-b^2; 3)y=1/(a+b)');
read(i);
if i=1 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a+b)*(a+b));
end
else begin
if i=2 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a*a)-(b*b));
end
else begin
if i=3 then begin
writeln('Введите a и b');
read(a,b);
write('y=',1/(a+b));
end;
end;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?