В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
яся72
яся72
06.06.2022 00:22 •  Информатика

Написать программу на паскале, используя вместо for - while. ! 1. напишите программу, которая в последовательности из 12 натуральных чисел определяет минимальное чётное число. программа получает на вход натуральные числа. в последовательности всегда имеется чётное число. введённые числа не превышают 30 000. программа должна вывести одно число – минимальное чётное число. 2. напишите программу, которая в последовательности из 12 натуральных чисел определяет максимальное число, оканчивающееся на 2. программа получает на вход натуральные числа. введённые числа не превышают30 000. программа должна вывести одно число – максимальное число, оканчивающееся на 2.

Ответ:
nikfyodorov20
nikfyodorov20
15.07.2020 16:27
1) 
 var
    a ,i,min: integer;
begin
min := 30000;
 i := 0;
 while i <> 12 do
  begin
   readln(a);
   if (a<min) and (a mod 2 = 0) then
    min := a;
   i := i +1;
  end;
writeln (min);
end.

2)
 var   
a ,i,max: integer;
begin
max := 0;  i := 0; 
while i <> 12 do 
begin   
readln(a);   
if (a>max) and (a mod 10 = 2) then   
max := a;   
i := i +1; 
end;
writeln (max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?