В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

2. написать программу, которая вводит массив из n целых чисел и выводит на экран элементы, кратные числу k. протестировать программу на следующих исходных данных: а) k=3 массив: 2 6 -9 4 5 12 -15 б) k=4 массив: 9 0 8 124 -16 11 19 на паскале

Ответ:
lyisa
lyisa
15.07.2020 15:29
Var 
a:array [1..100000] of integer;
i,n,k:integer;
begin
writeln('Введите n и k');
readln(n,k);
for i:=1 to n do
begin
writeln('Введите элемент №',i);
readln(a[i]);
end;
writeln('Весь массив:');
for i:=1 to n do
write(a[i],' ');
writeln();
writeln('Числа кратные ',k,':');
for i:=1 to n do
if a[i] mod k = 0 then
write(a[i],' ');
end.
ТЕСТ №1:
Весь массив:
2 6 -9 4 5 12 15 
Числа кратные 3:
6 -9 12 15 

ТЕСТ №2:
Весь массив:
9 0 8 124 -16 11 19 
Числа кратные 4:
0 8 124 -16 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?