В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ionutamaria90
Ionutamaria90
29.06.2021 22:02 •  Информатика

Паскаль авс , при функции trunc() в паскале можно реализовать операции целочисленного деления и взятия остатка от деления. например: целочисленное деление - trunc(491/240) - результатом будет 2; остаток от деления - 491-240*trunc(491/240) - результатом будет 11. используя функцию напишите программу, считающую сдачу в денежной системе (в этой денежной системе 1 фунт стерлингов равен 20 шиллингам, а 1 шиллинг равен 12 пенсам). напишите программу, в которой в трёх константах хранится стоимость товара. одна константа - фунты (целое значение больше нуля), вторая - шиллинги (значение от 0 до 19), третья - пенсы (значение от 0 до 11). ещё в трёх таких же константах хранится плата покупателя. используя одну целочисленную переменную, программа должна сосчитать и вывести на экран сдачу в фунтах, шиллингах и пенсах. не использовать условный оператор программа должна быть написана на паскале авс

Ответ:
Angelina922
Angelina922
15.07.2020 15:30
В одном фунте 20*12=240 пенсов.
Стоимость товара: F1 - фунты, S1 - шиллинги, P1 - пенсы
Плата покупателя: F2 - фунты, S2 - шиллинги, Р2 - пенсы
Х - сдача в пенсах

const
  f1=11;
  s1=5;
  p1=3;
  f2=12;
  s2=10;
  p2=0;
var
   x:integer;
begin 
x:=f2*240+s2*12+p2-f1*240-s1*12-p1; 
writeln('Сдача:'); 
writeln('фунтов ',trunc(x/240)); 
x:=x-240*trunc(x/240); 
writeln('шиллингов ',trunc(x/12)); 
x:=x-12*trunc(x/12); 
writeln('пенсов ',x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?