В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
koc12
koc12
01.01.2020 19:35 •  Информатика

Нужно вытянуть ! напишите процедуру ввода n элементов массива из файла. отсортируйте по невозрастанию методом простого обмена. (паскаль)

Ответ:
uhudongoair
uhudongoair
02.10.2020 05:05
Var  i,j,n,k: integer; 
 a: array [1..100] of integer;
begin
assign (input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
readln (n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do 
for j:=1 to n-i do
 if a[j+1]>a[j]
then begin k:=a[j]; a[j]:=a[j+1]; a[j+1]:=k; end;
for i:=1 to n do
write (a[i],' ');
end.

Входные данные писать в файл input.txt в формате:
n
a[i] a[i+1] a[i+2]...a[n].
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?