В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Даша83934
Даша83934
06.10.2022 08:50 •  Информатика

20 mod x = 20 div x найти x через паскаль(составить программу)! ответ: 9,19

Ответ:
yuliua88
yuliua88
02.10.2020 05:05
Program eq;
uses crt;
var x: integer;
begin
for x:=1 to 20 do if (20 mod x)=(20 div x) then writeln(x);
readln;
end.

Пояснение, почему значение x взято  до 20. Дело в том, что после 20 результат ф-ции 20 mod x всегда будет равен 20, а ф-ции 20 div x всегда будет равен 0.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?