В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Викуся22566
Викуся22566
02.10.2020 02:27 •  Информатика

Написать программу в паскалabc даны 3 числа. определить, можно ли построить треугольник с указанными сторонами.

Ответ:
repkinvasya
repkinvasya
15.07.2020 13:24
Program triangle;
var
max,a,b,c,s:integer;
begin
readln(a,b,c);
max:=a; 
if b > max then begin 
 max:=b;
  s:=a+c; 
 if s > max then writeln('Мoжно')   
 else     
writeln('Нельзя');   
 end;   
if c > max then begin   
max:=c;   
s:=a+b;   
 if s > max then writeln('Мoжно')     
 else     
writeln('Нельзя');   
 end   
  else 
   s:=c+b;   
 if s > max then writeln('Мoжно')     
  else    writeln('Нельзя');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?