Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
apabud
11.07.2022 11:22 •
Информатика
Дано натуральное число n. составьте программу, которая определяет входит ли цифра 6 в запись числа n^2.
Ответ:
ifraank
15.07.2020 12:56
#include <iostream>
#include <cmath>
using namespace std;
int main() {
int n=0;
cin>>n;
long long nn=pow(n,2);
cout<<nn<<endl;
while(nn!=0)
{
if(nn%10==6){cout<<"DA"; break;}
nn/=10;
}
if(nn==0)cout<<"NET";
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
torra11
29.11.2021 11:09
Размер графического изображения — 200 х 150 точек, глубина цвета на одну точку составляет 16 бит. Інформационный объем данного изображениябайт(-а).составляет...
znaniya1402
03.11.2021 12:06
Выбери, что по правилам техники безопасности можно делать в кабинете информатики, а чтонельзя...
Natashakr10
08.04.2023 02:18
Что такое звуковая карта?Это устройство для записи и воспроизведения звука на компьютере.Это устройство для воспроизведния звука на компьютере.Это устройство для записи и...
jixecizagjixeci
06.04.2023 21:00
Решить логическое выражение (-m*n 0)+(n m) если m =-2 n=3...
12345Serik
09.06.2021 22:19
Люди подскажите как изменить дату создания содержимого презентации.у меня в прзентации дата стоит 2005 как поставить 2013...
малика2071
09.06.2021 22:19
Найти самую большую разницу между цифрами числа...
yanoobhelpme
28.04.2020 22:08
нужно. Сколько времени потребуется для ввода в память компьютера текста на 35 страницах с сканера и программы ABBYY FineReader, если известно, что на сканирование одной страницы...
tarasIT
01.05.2023 16:51
Каков информационный объем в килобайтах моноаудиофайла длительностью звучания 4 секунды при глубине звука 16 бит и частоте 44 кгц ?...
кріс2
01.05.2023 16:51
Матрица размером 5: 5 заполняется случайными числами, кроме главной диагонали.по главной диагонали пустить -1.найти количество элементов,оканчивающихся на ноль,отрицательных...
Marrrrrrk
16.10.2022 18:09
образования слова предложение. cрочно 1 суффиксальный приставочный приставочно-суффиксальный бессуффиксный сложение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <cmath>
using namespace std;
int main() {
int n=0;
cin>>n;
long long nn=pow(n,2);
cout<<nn<<endl;
while(nn!=0)
{
if(nn%10==6){cout<<"DA"; break;}
nn/=10;
}
if(nn==0)cout<<"NET";
return 0;
}