В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DRUGAЯ
DRUGAЯ
17.06.2021 04:56 •  Информатика

:составить программу решения . указания к выполнению: самостоятельно выполнить все этапы решения . ввод и вывод матрицы оформить в виде процедур. при необходимости выделить в алгоритмы и оформить их в виде подпрограмм.паскаль дана матрица, определить количество «особых» элементов. элемент считается «особым», если он больше суммы остальных элементов строки.

Ответ:
Aizere20060304
Aizere20060304
14.07.2020 22:25
Const
  n = 10;
  m = 10;

type
  Matrix = array[1..n, 1..m] of integer;

procedure EnterMas(var Mas: Matrix);
var  i, j: integer;
begin
  randomize;
  for i := 1 to n do
    for j := 1 to m do
      Mas[i, j] := random(100);
end;

procedure GiveMas(var Mas: Matrix);
var  i, j: integer;
begin
  for i := 1 to n do
  begin
    for j := 1 to m do
    begin
      write(Mas[i, j], ' ');
    end;
    writeln;
  end;
end;

function SumStroki(Mas: Matrix; i, k: integer): integer;
var
  j, sum: integer;
begin
  sum := 0;
  for j := 1 to m do
    Sum := Sum + Mas[i, j];
  SumStroki := sum - k;
end;

function Element(var Mas: Matrix): integer;
var
  i, j, count: integer;
begin
  count := 0;
  for i := 1 to n do
    for j := 1 to m do
      if Mas[i, j] > SumStroki(Mas, i, Mas[i, j]) then inc(count);
  Element := count;
end;

var  Mas: Matrix;
  Sum, Max: integer;

begin
  EnterMas(Mas);
  GiveMas(Mas);
  writeln('Кол-во особых элементов ', Element(Mas));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?