В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
slv13
slv13
06.07.2020 08:38 •  Информатика

Дан масcив из n целых чисел. написать программу,определяющую ,сколько в массиве чисел, равных максимальному элементу массива.

Ответ:
4РИМ
4РИМ
14.07.2020 21:50
Uses   crt;
const  M = 100;
var  a: array [1..M] of integer; 
       i, max, k, n: integer;
begin  clrscr;   
repeat   
  writeln('Введите количество элементов массива');   
  readln(n); 
until (n <> 0) and (n>0);   

for i := 1 to n do 
begin   
   writeln('Введите [', i, '] элемент массива');   
   readln(a[i]); 
end;  

for i := 1 to n do   
 write(' ', a[i]);   

 writeln;   

max := a[1]; 
for i := 2 to n do  
   if a[i] > max then max := a[i]; 
writeln(' max= ', max);   

for i := 1 to n do   
   if a[i] = max then k := k + 1;   
writeln(' k= ', k);   
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?