В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zaharovdv73
zaharovdv73
10.04.2020 03:34 •  Информатика

Информатика 9 класс. составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов, которые больше своего соседа справа. пример вывода: исходный массив: 10 2 4 1 3 5 7 8 2 7 количество элементов, которые больше своего соседа справа=3 буду

Ответ:
veronikavolkova357
veronikavolkova357
02.10.2020 04:13
Const   N=10;
var   a:array [1..N] of integer;   
      k,i:integer;
begin 
randomize; 
for i:=1 to N do  
    begin 
    a[i]:=random(10)+1; 
    write (a[i], ' '); 
end; 
for i:=1 to N-1 do  
   if a[i]>a[i+1] then k:=k+1;  
writeln('k= ', k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?