В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
солнвшко
солнвшко
05.12.2021 15:33 •  Информатика

Паскаль авс составить программу, которая создает массив случайных чисел размером (n x m), выводит его на экран и вычисляет произведение ненулевых элементов массива.

Ответ:
tate6
tate6
14.07.2020 21:09
Program asd;
Const n=5; 
         m=4;
Var i,j,p:integer;
 A:array[1..n,1..m] of integer;
BEGIN 
For i:=1 to n do  
 begin 
 For j:=1 to m do  
  begin 
   A[i,j]:=Random(10);     
   Write(A[i,j]:3);
    end;   
 Writeln; 
end;   
 P:=1;  
 For i:=1 to n do  
  For j:=1 to m do  
  begin 
  if A[i,j]<>0 then p:=p*A[i,j];   
end; 
Writeln('Произведение ненулевых элементов массива: ',p); 
 END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?