В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
047oksana
047oksana
06.03.2023 17:48 •  Информатика

Написать программу, определяющую, принадлежит ли точка с координатами (x,y) кольцу с центром (x0,y0). r1 и r2 соответственно радиусы внутренней и внешней окружностей, образующих кольцо.

Ответ:
PeaceMaker1337
PeaceMaker1337
02.10.2020 04:12
Var  x,y,r1,r2:real;
begin
write('Введите x, y, внутренний радиус, внешний радиус: ');
readln(x,y,r1,r2);
if (x*x+y*y<=r2*r2) and (x*x+y*y>=r1*r1) then
  writeln('Да, принадлежит')
  else writeln('Нет, не принадлежит');
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?