В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
кошка448
кошка448
10.01.2023 11:05 •  Информатика

Программа делфи. язык паскаль. напишите программу нахождения всех трёхзначных чисел, сумма цифр которых равна а

Ответ:
milena7772
milena7772
14.07.2020 19:17
Program Project2;
{$APPTYPE CONSOLE}
uses  SysUtils; 
 Const n=30; 
     m=1;
var b,c:array[m..n] of integer;
i,a,s,y,s1:integer;
BEGIN
Write('Vvedite trexsnachnoe chislo A: ');
 readln(a); 
y:=a; s:=0; 
while ( y<>0 ) do 
 begin 
  s:=s + (y mod 10); 
  y:=y div 10;
 end;
Writeln('Summa zifr ravna: ',s);
Writeln;
Writeln('Massiv: ');
For i:=m to n do
  begin 
b[i]:=100+Random(200);
 Write(b[i],' '); 
c[i]:=b[i];
 end;
Writeln;   Writeln; 
 Write('Vse chisla, kotorye ravny po summe zifr: ') ;
 For i:=m to n do  
 begin 
 s1:=0; 
while ( b[i]<>0 ) do 
 begin 
 s1:=s1 + (b[i] mod 10); 
 b[i]:=b[i] div 10; end; 
 //Write(' ',S1,' '); 
  If s=s1 then   
begin 
  Write(c[i],' '); 
  end;  end;   
   Readln; 
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?