В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nastyaninisvn
Nastyaninisvn
02.03.2023 11:36 •  Информатика

На языке программирования паскаль составить программу суммы нахождения суммы вводимых с клавиатуры положительных чисел . печать результата по вводу 0 ( используя цикл while т.е. предусловие ).

Ответ:
vladimirdement
vladimirdement
25.05.2020 17:16

var

 a, s: real; //a - вводимое с клавиатуры число, s - сумма чисел

 

begin

  a:= 1;  //Присваиваем начальное значение, чтобы цикл выполнился

  s:= 0;

  while a <> 0 do   

  begin

    writeln('Введите положительное число');

    readln(a);

    if a < 0 then

    begin

      writeln('Введено не положительное число. Повторите ввод заново');

      continue; {Если а - не положительное число, вводим число заново}

    end;

    s:= s + a;

  end;

  writeln('Сумма:  ', s);  //Выводим сумму

end.

  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?