В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Noa18
Noa18
13.09.2022 02:50 •  Информатика

:написать программу на паскале, с (с++) или бейсике. входной файл: input.txt. выходной файл: output.txt. ограничение времени выполнения программы: 1 секунда на тест. спецификация входа: в первой строке входного файла записано целое число n (1 n 1000), во второй строке файла записаны целые числа x1, x2, xn, (-109 xi 109). спецификация выхода: запишите в выходной файл числа xi в порядке неубывания. пример входа: 5 12 10 5 10 7 пример выхода: 5 7 10 10 12

Ответ:
aylincik930
aylincik930
25.05.2020 17:15

program exs;
var a : array [1..1000] of integer;
n, i : integer;

procedure qsort(l, r: integer);
var i, j, key, buf : integer;
begin
i := l;
j:= r;
key:=a[(l+r) div 2];
repeat
while a[i] < key do inc(i);
while a[j] > key do dec(j);
if i<=j then begin
buf:=a[i];
a[i]:=a[j];
a[j]:=buf;
inc(i);
dec(j);
end;
until (i>j);
if (l < j) then qsort(l, j);
if (i < r) then qsort(i, r);
end;

begin
readln(n);
for i:= 1 to n do begin
read(a[i]);
end;
qsort(1, n);
for i:=1 to n do begin
write(a[i], ' ');
end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?