В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
erik09hfilya
erik09hfilya
15.06.2022 12:46 •  Информатика

Написать программу, которая находит сумму элементов последовательности из 5 целых чисел. получить новую последовательность путем замены всех ненулевых элементов исходной последовательности на разность между элементом последовательности и найденной суммой.

Ответ:
sanay06
sanay06
14.07.2020 13:25
Program Project1;
var   
a:array[1..5] of Integer;   
i, j, sum:Integer;   
s:string;
begin 
Readln(s); 
sum:=0; 
 for i:=1 to 5 do 
    begin   
         if (Length(s)>=2) then   
            begin     
              j:=Pos(' ', s);     
             a[i]:=StrToInt(Copy(s, 1, j-1));     
             sum:=sum+a[i];     
             Delete(s, 1, j);   
             end   
         else   
     begin     
      a[i]:=StrToInt(s);     
      sum:=sum+a[i];   
    end; 
end; 
   for i:=1 to 5 do 
      begin   
         if (a[i]<>0) then   
              begin     
                a[i]:=a[i]-sum;     
                Write(a[i], ' ');   
              end   
         else   
           begin     
              a[i]:=a[i];     
              Write(a[i], ' ');   
           end; 
      end; 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?