В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
amina555658
amina555658
14.03.2021 10:36 •  Информатика

Составьте программу которая заполняет массив а[1..10] заполните случайными целыми числами в диапазоне от 0 до 2 и выводит количество элементов,равных 1.

Ответ:
111dashamm639
111dashamm639
14.07.2020 12:42
VAR a:array[1..10] of integer;
        i,s:integer;
BEGIN
    s:=0;
    for i:=1 to 10 do
        begin
            a[i]:=random(3);
            if a[i]=1 then s:=s+1
        end;
    writeln ('Массив a: ');
    for i:=1 to 10 do write (a[i],' ');
    writeln;
    writeln ('Элементов массива, равных одному: ',s)
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?