В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rkarina79
rkarina79
22.06.2020 20:12 •  Информатика

Язык pascal abc. напишите программу: дан двухмерный массив a[1..m,1..n]. написать программу построения одномерного массива b[1..m], элементы которого соответственно равны суммам элементов строк.

Ответ:
определение1
определение1
13.07.2020 23:48
Const
 m=100;
 n=100;
var
a:array[1..m,1..n]of integer;
b:array[1..m]of integer;
i,j:integer;
begin
for i:=1 to m do
for j:=1 to n do
 a[i,j]:=random(200)-100;
for i:=1 to m do
b[i]:=0;
for i:=1 to m do
for j:=1 to n do
b[i]:=b[i]+a[i,j];
for i:=1 to m do
write(b[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?