В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
instajoha1p0917j
instajoha1p0917j
17.04.2020 13:20 •  Информатика

Решить на паскале на компьютере: найти сумму нечетных положительных чисел из n введенных чисел. заранее ! (через for) program z1; var i,a: real; s,n: integer; writeln('введите кол-во чисел'); readln(n); s: =0; for i: =1 to n do begin; readln(a); if a mod 2 < > 0 and a> 0 then begin s: =s+a end; end; writeln (s); end. начала решать, не

Ответ:
BlankDawn
BlankDawn
02.10.2020 03:21
var a,s,mn:real;     n,i:integer; begin clrscr; repeat write('Сколько чисел ввести n>0 n='); readln(n); until n>0; writeln('Введите ',n,' чисел:'); s:=0; for i:=1 to n do  begin   write('a=');   readln(a);   if i=1 then mn:=a   else if odd(i)and(a<mn) then mn:=a;   if(i mod 2=0)and(a>0) then s:=s+a;  end; writeln('Сумма положительных с четными индексами=',s:0:2); writeln('Минимальный с нечетным индексом=',mn:0:2); readln end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?