Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ФамилГасанов
26.09.2022 02:54 •
Информатика
Составить программу вычисляющую периметр ромба, если известны его диагонали.(pascal)
Ответ:
romanovegorka6
13.07.2020 22:10
Program qq;
var p,d1,d2:real;
begin
write('Введите значение 1 диагонали');
readln(d1);
write('Введите значение 2 диагонали');
readln(d2);
p:=4*sqrt((sqr(d1)/2)+(sqr(d2)/2));
write('Периметр ромба=',p);
end.
Вроде так, но может быть ошибка
0,0
(0 оценок)
Популярные вопросы: Информатика
илья1598
01.12.2021 20:27
Информационное сообщение I= 370 байт, состоит из 546 символов. Каков информационный вес каждого символа этого сообщения? Какова мощность алфавита, с которого написано...
DiaPika
04.12.2022 07:13
Дано число (31204)x,записанное в некоторой системе счисления с основанием x .выберите значения x,для которых запись этого числа является корректной: а)x=8 ,б) x=3 ,в)x=16...
glushkovaov
12.10.2022 11:01
1.что такое ярлык? 2.зачем ярлыки папок и файлов? 3.зачем ярлыки программ ? 4.как ярлыки экономят место на диске? 5.чем отличается удаление значка папки от удаления ярлыка...
TimuR2112
30.04.2023 11:43
Дан список чисел. определите, сколько в этом списке элементов, которые больше двух своих соседей и выведите количество таких элементов. входные данные вводится список...
kazakstanarmy
30.04.2023 11:43
8класс страница 29 №7 a)=a1+a2 b)=a1+a2/a1-a2 c)=(a1+a2)/(a1-a2) d)=a1*a1+a2/2 e)=a1*(a1+a2)/a2 f)=a2 g)=a1 a2 h)=b1& b2 i)=b2& b1 j)=b1& & b2...
ляляля06
19.11.2022 18:17
Создайте словарь рыбы а его элементы разделить на три вида речные озерные и морские...
a06b07c2005
17.01.2020 21:24
Вчем состоит особенность компьютерного моделирования в процессе техническим устройством...
Dimoooon12321
17.01.2020 21:24
Вчем состоит особенность компьютерного моделирования в процессе техническим устройством...
nikitaefimenko
17.01.2020 21:24
Устудента есть список из четырех вопросов, на один из которых он должен будет ответить. вероятность, что студенту придется отвечать на первый вопрос, равна 0,3, на второй...
Catia2006
17.01.2020 21:24
Считая что каждый символ кодируется одним байтом оцените информационный обьем следующегося высказывания онера же : ключом ко всякой науке является вопросительный знак.1)52;...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var p,d1,d2:real;
begin
write('Введите значение 1 диагонали');
readln(d1);
write('Введите значение 2 диагонали');
readln(d2);
p:=4*sqrt((sqr(d1)/2)+(sqr(d2)/2));
write('Периметр ромба=',p);
end.
Вроде так, но может быть ошибка