В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ladychoco
ladychoco
23.05.2022 17:44 •  Информатика

Дано двухзначное(трехзначное)число. напишите программу определения - входит ли в него цифра 5 -входят ли в него цифры 4 и 7

Ответ:
Valeriya2576
Valeriya2576
13.07.2020 20:13
Var a,b,c,d:integer;
begin
readln(a);
b:=a div 100;
c:=a mod 100 div 10;
f:=a mod 100 mod 10;
if (b=5) or (c=5) or (f=5) then write('входит')
else write('невходит');
if (b=7) or (b=4) or  (c=7) or (c=4) or (f=7) or (f=4) then write('входит')
else write('невходит');
end.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?