В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DavtynGalia
DavtynGalia
13.08.2021 03:47 •  Информатика

Написать программу на си++.6 нужно

Ответ:
catkama
catkama
25.05.2020 16:47

Ну, раз матрица дана, пусть она будет А. Напишу в общем случае, так как я не знаю ее размер. Пусть она будет размера n×n.

Дальше код по заданию:

include <iostream>

using namespace std;

void main()

{

double A[5][5];

int n = 5;

for(int i = 0; i < n; i++)

{

int k = i;

for(int j = 0; j< n; j++)

{

A[i][j] = k*2;

}

}

double max = A[0][1];

for(int i = 1; i < n; i++)

{

int j = 1;

if(max < A[i][j])

max = A[i][j];

}

for(int i = 0; i < n; i++)

{

for(int j = 0; j < n; j++)

{

if(max>A[i][j])

{

cout << "Номер строки: " << i << "Номер столбца: " << j << endl;

}

}

}

Вроде бы так)

0,0(0 оценок)
Ответ:
galinapetrovic
galinapetrovic
25.05.2020 16:47
inputStd() - функция, обеспечивающая безопасный ввод целочисленных значенийfillMatrix() - функция, заполняющая квадратичную матрицу (далее - матрицу) числами из потока вводаexpandMatrix() - функция, которая расширяет вектор из столбцов векторов из целочисленных значений до размера SIZE x SIZEoutputMatrix() - функция, выводящая элементы матрицыfindMax() - функция, находящая максимальный элемент во втором столбце матрицыfindColumnAndStr() - функция, выводящая строку, столбец и значение ячейки, если она меньше максимального элемента второго столбца

Если что-то непонятно - задавайте вопросы в комментарии.


Написать программу на си++.6 нужно
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?