В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Амбрела123
Амбрела123
17.03.2022 14:09 •  Информатика

Составить программу, которая проверяет правопис "жи", "ши" и выводит количество ошибок и исправленную строку

Ответ:
Соня11647
Соня11647
13.07.2020 18:25
Var
a,count:longint;
s:string;
begin
writeln('введите строку');
count:=0;
read(s);
while pos('жы',s)>0 do 
begin
 inc(count);
 a:=pos('жы',s);
 delete(s,a,2);
 insert('жи',s,a)
end;
while pos('шы',s)>0 do 
begin
 inc(count);
 a:=pos('шы',s);
 delete(s,a,2);
 insert('ши',s,a)
end;
writeln(s);
writeln('всего ошибок: ',count)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?