Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ForaN777
28.08.2022 03:29 •
Информатика
Создать массив из 10 целых чисел и отсортировать методом пузырька по убыванию. c++
Ответ:
tonplaton
02.10.2020 02:55
#include <cstdio>
#include <iostream>
using namespace std;
int main ()
{
int n = 10;
int a[11];
srand(time(NULL));
for (int i = 0; i < n; i++)
{
a[i] = rand() % 100;
}
for (int i = 0; i < n; i++)
for (int j = 1; j < n; j++)
{
if (a[j - 1] < a[j])
swap(a[j - 1], a[j]);
}
for (int i = 0; i < n; i++)
{
cout << a[i] << " ";
}
}
srand( ) нужен для генерации каждый раз новой последовательности рандомных чисел
0,0
(0 оценок)
Популярные вопросы: Информатика
mixkorabin
03.07.2021 18:48
Дан диаметр окружности. найти радиус. в pascal abc...
прп30
03.07.2021 18:48
Программа на pascal: вводятся целые числа. признак конца - ввод числа 0. определить, сколько двузначных четных чисел, оканчивающихся на 2, расположено между 2-ым и 5-ым числами !...
Ruda05
03.07.2021 18:48
Число 1110100 в восьмиразрядном представлении имеет вид: 110100 2110100 100110100 01110100...
nikas45
04.02.2021 17:50
Напишите на паскале ,. вот : введится 10 чисел,определите сколько положительных и отрицательных....
влад2610
28.02.2021 20:21
Все ,только напишите программу паскаль для вычисления данного примера x^2=5cos(x-1)...
RomashechkaRomova
10.07.2021 01:53
Даны 3 числа a,b,c если они не равны то замените все чилса наибольшим из них и выведите результат на экран иначе найдите и вывидите сумму квадратов этих чисел...
styopyshca
10.07.2021 01:53
Написать программу(паскаль) 2. для заданного набора коэффициентов a, b, c, d найдите наименьшее значение функции y = a x3 + b x2 + cx + d и значение аргумента, при котором оно получено....
khezh073
10.07.2021 01:53
Составить алгоритм и программу для нахождения суммы ряда: s=x^1+x^3+x^5+x^7++x^13...
Злая4Пташка4
10.07.2021 01:53
Написать программу.(информатика) 1)элементы заданного массива x = (x1 , x2, ) переупорядочите следующим образом: x = (xn , xn-1 , x1 )....
lllaasaw
30.10.2022 11:38
Даны два целы числа a и b.заменить большее из числе произведением а меньшее суммой.pascalabc...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
using namespace std;
int main ()
{
int n = 10;
int a[11];
srand(time(NULL));
for (int i = 0; i < n; i++)
{
a[i] = rand() % 100;
}
for (int i = 0; i < n; i++)
for (int j = 1; j < n; j++)
{
if (a[j - 1] < a[j])
swap(a[j - 1], a[j]);
}
for (int i = 0; i < n; i++)
{
cout << a[i] << " ";
}
}
srand( ) нужен для генерации каждый раз новой последовательности рандомных чисел