В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
anastaiyaersho
anastaiyaersho
21.12.2022 12:23 •  Информатика

Склавиатуры вводят строку. составить программу, которая удаляет из строки последнее слово

Ответ:
эмирия
эмирия
13.07.2020 15:27
Program aaa;
var
a,i:longint;
s:string;
begin
read(s);
a:=0;
for i:=1 to length(s) do 
if s[i]=' ' then a:=i; //находим последний пробел
delete(s,a,length(s)-a+1); //удаляем из строки последнее слово
writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?