В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mazieva82872
mazieva82872
16.12.2020 05:56 •  Информатика

С# дан массив, состоящий из целых чисел. напишите программу, которая подсчитывает количество положительных чисел среди элементов массива. входные данные сначала задано число n — количество элементов в массиве (1n10000). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо единственное число - количество положительных элементов в массиве. примеры входные данные 5 1 2 3 -1 -4 выходные данные 3

Ответ:
Anyta31107
Anyta31107
13.07.2020 10:31

using System;

namespace znanja

{

   class Program

   {

       static void Main(string[] args)

       {

           int num = int.Parse(Console.ReadLine());

           int[] array = new int[num];

           array = Array.ConvertAll(Console.ReadLine().Split(' ', StringSplitOptions.RemoveEmptyEntries), int.Parse);

           int count = 0;

           for (int i = 0; i < num; i++)

           {

               if (array[i] > 0) count++;

           }

           Console.WriteLine(count);

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?