В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vedmochkasalyt
vedmochkasalyt
02.02.2021 06:09 •  Информатика

Информатика составить программу, которая формирует массив из 12 случайных целых чисел, принадлежит промежутку [ -20, 20 ], заменяет отрицательные числа на -1 и выводит значения элементов массива до и после замены. : -)

Ответ:
ilona10022002
ilona10022002
13.07.2020 10:49
Var
  a: array [1..12] of integer;
  i: integer;
begin
  writeln('Начальный вид массива:');
  for i := 1 to 12 do
   begin
    a[i] := -20 + random(41);
    writeln('A[', i:2, ']=', a[i]:3);
  end;
  writeln('Конечный вид массива:');
  for i := 1 to 12 do
   begin
    if a[i] < 0 then a[i] := -1;
    writeln('A[', i:2, ']=', a[i]:3);
  end;
  readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?