В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pd101
pd101
08.03.2020 08:08 •  Информатика

На pascal abc,решить используя type надо) составить программу которая создает файл каждая строка которого выглядет так: табельный номер,фио,оклад. ввести в файл данные о 5-ти работниках и вывести в другой файл максимальный оклад

Ответ:
godd1
godd1
25.05.2020 16:22


var i,max:integer; fio:string; x:array[1..5] of integer;
    F1,F2:text;
begin
 assign(F1, 'out.txt'); assign(F2, 'out2.txt');
 rewrite(F1); rewrite(F2);
 for i:=1 to 5 do
   begin
     writeln('daite FIO ',i,'-ogo rabotnika'); readln(fio);
     writeln('daite otklad rabotnika ',i); readln(x[i]);
     writeln(F1, i,' ',fio,' ',x[i]); fio:='';
   end;
   max:=x[1];
   for i:=1 to 5 do if x[i]>max then max:=x[i];
   writeln(F2, max);  close(F1); close(F2);
 readln;
end.

 

rabotatet! proveril v PASCALE

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?