Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
suxova1985251030
29.03.2023 00:42 •
Информатика
Написать программу, которая запрашивает у пользователя номер товара и выводит его название (не менее 5 товаров). если пользователь указывает недопустимое число, то выво-дится сообщение «ошибка ввода данных»
Ответ:
keckush
13.07.2020 08:42
type goods = record name:String; price:real; end;const GOODS_COUNT = 5;var goodsList:array[1..GOODS_COUNT] of goods;id:integer;begin goodsList[1].name:='iPhone 5s'; goodsList[1].price:=760.0; goodsList[2].name:='Samsung Galaxy s5'; goodsList[2].price:=540.0; goodsList[3].name:='Simens m60'; goodsList[3].price:=12.5; goodsList[4].name:='HTC ONE X'; goodsList[4].price:=450.5; goodsList[5].name:='LG L9'; goodsList[5].price:=600.0; write('Write goods id:'); readln(id); if ( ( id < 0 ) or ( id > GOODS_COUNT ) ) then writeln('WRONG ID') else writeln(goodsList[id].name,' price =',goodsList[id].price); end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Demiali41
16.11.2021 10:39
Нужно написать любой текст и посчитать его емкость в битах(код 8 и universal code(16 бит) кто знает объясните !...
lolik334
23.01.2022 07:25
Решить через подпрограмму и без рандома дано: массивы а(8),в(11). определить в каком массиве отрицательное число встречается раньше. номер первого отрицательного элемента в массиве...
Тлопап
07.04.2021 23:37
Для какого из чисел истинно высказвание : не ( первая цифра четная ) и не ( вторая цифра нечетная)?...
lera24012002
07.04.2021 23:37
Брошюра содержит 24 страниц на каждой из которых в среднем по 32 строки, содержащих 64 символов каждая. сколько килобайт составляет информационный объём текстового файла с брошюрой,...
Илья2389
07.04.2021 23:37
Даны два числа возвести в квадрат те из них которые отрицательные...
BMOPLAY23
07.04.2021 23:37
1.исполнитель черепашка перемещается на экране компьютера, оставляя след в виде линии. в каждый конкретный момент извест- но положение исполнителя и направление его движения. у исполнителя...
ledzep
26.07.2022 02:56
Найти величины 4метров15дациметров= дм...
Maks2801
19.08.2020 22:49
9. lake ontario is in north america.a) the, –b) —, thec)-, -10. independence avenue is longest street in the city.a) the, —b) — , the11. the flowers are dry. i water them.a) willb)...
zed666776ozkrhw
21.08.2022 05:13
Построить график функции у=2х-3 и найти координаты точки пересечения этого графика с прямой у=-5х+11...
Loskinstem5617
06.06.2022 08:01
Найдите целые решения неравенства: 3х^2-7х+2меньше равно 0...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?