Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
KateySh
30.08.2022 17:59 •
Информатика
Паскаль авс.net составить программу с записью дата. программа должна обеспечивать простейшие функции для работы с данными : увеличение/уменьшение на 1 день, ввод значений , вывод значений. .
Ответ:
настюха20998
13.07.2020 07:48
Uses
System;
var
d1, d2: DateTime;
s: string;
begin
Write('Введите дату в формате ДД.ММ.ГГГГ: ');
Readln(s);
d1 := DateTime.Parse(s); { получили дату }
d2 := d1.AddDays(-1);
Writeln('Предыдущий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
d2 := d1.AddDays(1);
Writeln('Следующий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
end.
Тестовое решение:
Введите дату в формате ДД.ММ.ГГГГ: 31.12.2014
Предыдущий день: 30.12.2014
Следующий день: 1.1.2015
0,0
(0 оценок)
Популярные вопросы: Информатика
badyul
27.05.2020 00:34
Вопрос по программированию в питон: 1) Напишите программу, которая будет принимать числа от пользователя и суммировать их, пока он не напишет слово «sum». 2) Когда пользователь...
Aleksandr541
02.11.2021 01:00
Всем привет, я пишу программу на питон, при ручном вводе данных программа работает верно и не выдаёт ошибки, но при сдаче в тестирующую систему пишет Ошибка во время...
Mucuo31
10.06.2020 22:19
Дайте ответ сор у меня 6 класс...
виолетта111111111113
08.12.2020 03:04
На веб страницу под именем Моя любимая профессия вставьте рисунки,относящиеся к профессиям.Вокруг рисунка создавайте рамку размером 15 пикселей....
толька54
04.07.2021 01:31
Перевести в двоичную ,десятичную и шестнадцатеричную числа 333,777,1024...
ЯРОСЛАФ
24.12.2022 14:54
решить тест + 1 Какая из процедур является процедурой с параметром: А) ЭТО КВАДРАТ Б) ЭТО КВАДРАТ :А ПОВТОРИ 4 [ВП 40 ЛВ 90] ПОВТОРИ 4 [ВП :А ЛВ 90] КОНЕЦ КОНЕЦ 2 Какие...
starlizz
13.04.2020 02:14
Решите уравнения по теореме Виета. 1) 3x^2-18=0 2) 8x^2-3x=0 3) x^2-x-20=0 4) 3x^2-2x-8=0 5) x^2+6x-2=0 6) x^2-4x+6=0...
kek123121
26.09.2022 11:26
Правильно ли я написала? Есть ли ошибки? Если что, исправьте У меня сейчас ощущение как будто потерялось желание не хочу снимать видео и лень. Думаю, я завтра лучше сделаю...
evtpasha2017
29.05.2020 00:27
Какие упражнения на ноги нужно делать, чтобы убрать чересчур накаченные икры?...
Аиляра
13.04.2020 02:14
Чий це опис? Кругленький, як підпалок, з підпалкуватим, добре випеченим обличчям . Старший брат молодший брат гніда конячина дядько Шпичак...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
System;
var
d1, d2: DateTime;
s: string;
begin
Write('Введите дату в формате ДД.ММ.ГГГГ: ');
Readln(s);
d1 := DateTime.Parse(s); { получили дату }
d2 := d1.AddDays(-1);
Writeln('Предыдущий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
d2 := d1.AddDays(1);
Writeln('Следующий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
end.
Тестовое решение:
Введите дату в формате ДД.ММ.ГГГГ: 31.12.2014
Предыдущий день: 30.12.2014
Следующий день: 1.1.2015