В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nisawe
Nisawe
27.08.2020 02:37 •  Информатика

Составить программу ,которая формирует массив ,содержащий 12 случайных целых чисел ,принадлежащий промежутку [-7; 10],и подсчитывает кол-во всех отрицательный чисел

Ответ:
The0ruyman
The0ruyman
13.07.2020 07:24
#include <iostream>
#include <stdlib.h>      
#include <time.h>       

int main()
{
  srand(time(NULL));

  int a[12];
  int s = 0;
  for (int i = 0; i < 12; ++i){
    a[i] = rand() % 18 - 7;
    if (a[i] < 0) s++;
  }
  std::cout << s;
   return 0;
}
0,0(0 оценок)
Ответ:
помогите1170
помогите1170
13.07.2020 07:24
Паскаль:
var i,t:integer;
    a:array[1..12] of integer;
begin  randomize;
  for i := 1 to 12 do begin
    a[i] := round( random(17)-7 );
    write(a[i]:3);
  end;
  t := 0;
  for i := 1 to 12 do
    if a[i] < 0 then
      inc(t);
  writeln;
  writeln(t);
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?