Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
t22422
27.08.2020 02:37 •
Информатика
Дан массив из 8 элементов целого типа равный : -8,13,4,-6,7,10,-5.напишите программу ,которая заменит все положительные числа на 1 ,а все отрицательные увеличит на 10.преобразованный массив вывести на экран в строчку через запятую
Ответ:
MiFanMF
13.07.2020 07:24
#include <iostream>
int main() {
int a[] = { -8, 13, 4, -6, 7, 10, -5 };
for (int i = 0; i < 7; ++i)
std::cout << ((a[i] < 0) ? a[i] += 10 : a[i] = 1) << ",";
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
помогитеяглупая
08.01.2021 20:00
для какого числа х ложно высказывание : (х 8) или не (х 7)...
Ди1233
21.03.2023 09:54
Вячейке с4 ввели формулу =$а$1+с2. затем эту формулу распространили вправо. какая формула содержится в ячейке е4?...
31Maks31
03.05.2022 20:01
4. у амирхана на компьютере установлена антивирусна программа.обнаружено: вредоносное пора инеобеспечение.объект: с/samples26b8b796b2d9e3.7685троянская програми: trojan-ransom.win32pornoblocker.dk-...
эльза182
01.01.2022 20:50
Ограничение времени: 1 сограничение памяти: 256mулиточные бегакаждые 100 лет в стране улиток проводятся улиточные бега на дистанции l сантиметров. это станет для вас неожиданностью,...
Прост2004
12.11.2021 04:02
Укажите приблизительный объём школьного реферата...
kiryagartman
24.04.2020 10:33
Информатика не могу найти program n_15; var i: integer; x: real; begin writeln ( График тренировок ); i:=1; x:=10; repeat i:=i+1; x:=x+0.1*x; until x =25; writeln ( Начиная с ,...
arslanbaiguskap0c2gw
14.06.2022 20:06
Что будет выведено на экран в результате выполнения фрагмента программы: s: =0; for k: =0 to 10 do begin x: =-10+3*k; if x 0 then s: =s+1; write(x: 4); end; writeln(s); нужно подробное...
Pollyru
28.05.2021 14:53
1001011112₂→…8 б) 10010000101012₂→…16 в) 1518₈→…16 г) 1058₈→…10 д) 12110₁₀→…2...
Gesha11
05.06.2021 07:44
Python 3 Напишите программу, которая запрашивает натуральное число, и если последняя цифра этого числа больше 5, то вывести её на печать, иначе вывести число 0....
Kirillpakharenko
19.01.2022 01:11
Составьте мини-рассказ при плана: 1) какие нововведения появились у вас при переходе из начальной школы в основную? Что осталось прежним? 2)какие новые предметы у вас появились...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
int main() {
int a[] = { -8, 13, 4, -6, 7, 10, -5 };
for (int i = 0; i < 7; ++i)
std::cout << ((a[i] < 0) ? a[i] += 10 : a[i] = 1) << ",";
return 0;
}