В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Динара010
Динара010
07.03.2021 17:28 •  Информатика

На языке паскаль: 1. проверить, делится ли произведение пяти натуральных чисел на первое из них нацело. 2.определите количество двузначных чисел, сумма квадратов цифр которых делится без остатка на 15.

Ответ:
morkovcha
morkovcha
12.07.2020 23:21
1.
uses crt;
var a,b,c,d,e,f:integer;
begin
writeln ('vvedite 5 chisel');
read (a,b,c,d,e);
f:=a*b*c*d*e ;
if (f mod a)=0 
then writeln ('delitsa') 
else writeln ('nedelitsa');
end.

По поводу второй, не уверен, если под суммой квадратов цифр подразумевается 10 = 1*1+0*0, то эта программа неправильна, её нужно переписать будет. 
uses crt;
var a,i,s,t,t1:integer;
begin
for i:=10 to 99 do begin
t:=i div 10; t1:=i mod 10 ;
 if (sqr(t)+sqr(t1)) mod 15 = 0 
then s:=s+1; 
end; 
writeln (s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?