В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
malinka149
malinka149
12.12.2022 19:01 •  Информатика

Паскаль авс. дана строка символов. составьте программу которая подсчитывает, сколько в данной строке слов оканчивающихся на а. все слова разделяются 1 пробелом и только буквы.

Ответ:
kornilov1001
kornilov1001
12.07.2020 19:24
Var
  s: string;
  i, n: integer;
  a: set of char;

begin
  Writeln('Введите строку текста');
  Readln(s);
  n := 0;
  a := ['А', 'а'];
  for i := 1 to Length(s) do
    if (s[i] = ' ') and (s[i - 1] in a) then n := n + 1;
  if (s[i - 1] in a) then n := n + 1;
  Writeln('Количество слов, оканчивающихся буквой "а", равно ', n)
end.

Тестовое решение:
Введите строку текста
А роза упала на лапу Азора
Количество слов, оканчивающихся буквой "а", равно 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?