В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zero407
zero407
18.06.2020 09:24 •  Информатика

Задан периметр квадрата. составьте программу, с которой определите радиус вписанной и описанной окружности.

Ответ:
Novikovavera81
Novikovavera81
25.05.2020 14:45

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cmath>
using std::pow;
using std::sqrt;

double vpisannayaOkryzhnost(double);
double opisannayaOkryzhnost(double);

int main()
{
   double perimeter;

   cout << "Vvedite perimeter: ";
   cin >> perimeter;

   cout << "r vpisannoi okruzhnosti = " << vpisannayaOkryzhnost(perimeter) << endl;
   cout << "R opisannoi okruzhnosti = " << opisannayaOkryzhnost(perimeter) << endl;

   cin.get();
   return 0;
}

double vpisannayaOkryzhnost(double perimeter)
{
   double a = perimeter / 4;

   return (a / 2);
}

double opisannayaOkryzhnost(double perimeter)
{
   double a = perimeter / 4;

   return (sqrt(2) / 2 * a);
}

 

На Гэ-паскале можно написать так:

program math;
var perimeter, a: real;
begin
  write('Vvedite perimeter: ');
  read(perimeter);
  a := perimeter / 4;
  writeln('r vpisannoi okruzhnosti = ', a / 2:0:2);
  writeln('R opisannoi okruzhnosti = ', sqrt(2) / 2 * a:0:2);
  readln();
  readln();
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?