В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
LIZA555666777
LIZA555666777
22.03.2020 15:15 •  Информатика

Написать программу для решения a) удалить из текста все введенные символы. b) в заданном тексте после каждого знака ‘–’ и перед каждым таким знаком вставить пробел, если его там нет.

Ответ:
ралина35
ралина35
12.07.2020 15:04
Var
  s, s_rej, s2: string;
  i: integer;

begin
  Write('Введите текст: '); Readln(s);
  Write('Введите исключаемые символы ПОДРЯД: '); Readln(s_rej);
  s2 := '';
  for i := 1 to Length(s) do
    if Pos(s[i], s_Rej) = 0 then s2 := s2 + s[i];
  Writeln('Обработанный текст: ', s2)
end.

Тестовое решение:
Введите текст: Пример текста, из которого будут исключены гласные буквы
Введите исключаемые символы ПОДРЯД: аеёиоуэюя
Обработанный текст: Прмр ткст, з ктрг бдт склчны глсны бквы

var
  s, s2: string;
  i: integer;
  c:array of string;

begin
  Write('Введите текст: '); Readln(s);
  s:=Trim(s);
  c:=s.Split('-');
  s2:=Trim(c[0]);
  for i:=1 to Length(c)-1 do
    s2:=s2+' - '+Trim(c[i]);
  Writeln('Обработанный текст: ', s2)
end.

Тестовое решение:
Введите текст:    тестовая   -строка - в ней много-много тире в разных-  преразных вариантах - и в таком даже
Обработанный текст: тестовая - строка - в ней много - много тире в разных - преразных вариантах - и в таком даже
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?